Re: MyProxy install breaks globus-gatekeeper [was Re: Myproxy + grid]



Re-installing globus-gatekeeper from source code seems to fix the problem.
Does that mean that Myproxy works fine with it then? Just to clear up my
confuson.

Thanks Jim for working on this.

Jenny
UVIC Grid

On Thu, 27 Mar 2003, Jim Basney wrote:

> It appears to be a compatibility problem between the GT 2.2.4
> globus_gatekeeper binary release and the GT 2.2.4 globus_openssl update
> packages (to which a Globus Project Security Advisory applies; see
> http://www-unix.globus.org/mail_archive/security-announce/msg00004.html).
> I've submitted a Bugzilla report to the Globus Project
> (http://bugzilla.globus.org/bugzilla/show_bug.cgi?id=852).  Based on my
> tests, re-installing the globus_gatekeeper package from source appears to
> resolve it.  For example:
>
>    $ wget
> ftp://ftp.globus.org/pub/gt2/2.2/2.2.4/packages/src/globus_gatekeeper-2.1.tar.gz
>    $ $GPT_LOCATION/sbin/gpt-build -force -verbose gcc32dbg
> globus_gatekeeper-2.1.tar.gz
>
> At 09:26 AM 3/25/2003, Jim Basney wrote:
> >Jenny,
> >
> >I can reproduce the problem you reported.  After installing myproxy-1.4 on
> >top of globus-2.2.4, I get:
> >
> >   $ telnet localhost 2119
> >   Trying 127.0.0.1...
> >   Connected to denim.ncsa.uiuc.edu (127.0.0.1).
> >   Escape character is '^]'.
> >   globus-gatekeeper: relocation error: globus-gatekeeper: undefined
> > symbol: stat
> >   Connection closed by foreign host.
> >
> >There is some problem with the Globus libraries included in the MyProxy
> >bundle.  I'm investigating the problem now and will try to find a solution
> >ASAP.
> >
> >-Jim
> >
> >At 04:17 PM 3/24/2003, Jenny  Allan wrote:
> >>I installed the myproxy server 1.4 on a globus-2.2.4 server platform
> >>(grid.phys.uvic.ca). I
> >>also installed a myproxy client 1.4 on a globus-2.2.4 client/server
> >>(imp.phys.uvic.ca). A
> >>strange thing happened. The myproxy seemed to work fine (I could do
> >>myproxy-init and myproxy-get-delegation), I could also do globus-job-run
> >>from the client to the server no problem (whether I got my proxy from
> >>myproxy-init or from grid-proxy-init). However, if any other machines that
> >>do not have myproxy client installed,
> >>(that had previous to this, worked fine on the server ... they are in the
> >>grid-mapfile and all that) tried to do globus-job-run to the server
> >>I get error code 7: Cannot Authenticate for some reason.
> >>
> >>In all the things I've read it says that this is a grid-mapfile problem.
> >>However, I know that is not the problem. The only it seems that I could
> >>fix it is by reinstalling globus-2.2.4 and not installing myproxy. Is
> >>there something I should know (Ie... if you install myproxy, then any
> >>machines to use that grid resource has to have myproxy clients installed
> >>to work?)
> >>
> >>Jenny
> >>UVIC Grid Testbed
>
>



Other Mailing lists | Author Index | Date Index | Subject Index | Thread Index