update on MyProxy CoG compatibility


MyProxy users,

A Globus update package is now available that fixes the Java CoG 0.9.13 
incompatibility for recent MyProxy server releases.  Installing the 
globus_gssapi_gsi-3.12 update, available from 
<http://www-unix.globus.org/toolkit/2.2/advisories/>, makes MyProxy 0.5 
versions compatible with Java CoG 0.9.13.  These versions continue to be 
compatible with Java CoG 1.x, as well as the MyProxy C clients back to 
version 0.2.  Specifically, I've tested MyProxy 0.5.0 and 0.5.3 servers 
with the globus_gssapi_gsi-3.12 update against Java CoG 0.9.13 and 
1.1a.  Please let me know if you find any problems.

Future MyProxy releases will include the globus_gssapi_gsi-3.12 update in 
the MyProxy GPT bundle.

Please note that the Globus developers have not committed to maintaining 
this backwards compatibility with Java CoG 0.9.13 beyond the Globus Toolkit 
2.2 series.  Specifically, Globus Toolkit 2.4 will not be compatible with 
Java CoG 0.9.13.  So please begin upgrading your MyProxy Java CoG client 
installations to Java CoG 1.x as soon as possible.

I apologize for not catching these compatibility problems sooner.  We're 
working to improve our testing process to include more compatibility tests.

-Jim



Other Mailing lists | Author Index | Date Index | Subject Index | Thread Index