Expo/Information Center/Welcome

| Back |

Technical Considerations:Macintosh Platform

We recommend that you view this exhibit with the latest of any of the currently available browsers. In particular, make sure you are using NCSA Mosaic 2.01 (final release), Netscape 1.12 or Spyglass Mosaic 2.0, or later versions of any one of these browsers. Older versions will NOT display all the multimedia information inside this exhibit. Another point to note is many of the pages are Netscape optimized, so that they may appear slightly different from how they were intended with other browsers. If you are currently using an older version of any of these browsers, use the links below to download the most current versions:


Besides the browser, you will need the following external applications in order to experience fully the multimedia features of the exhibit. Note there are many other programs available to accomplish the same task just as well.

Return to Technical Corner

Copyright 1995, The Board of Trustees of the University of Illinois


NCSA, 11/18/95. kmackie@ncsa.uiuc.edu